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3 Creating and 
Editing Symbols

Lesson Overview
In this lesson, you’ll learn how to do the following:

•	 Import Illustrator and Photoshop files

•	 Create new symbols

•	 Edit symbols

•	 Understand the difference between symbol types

•	 Understand the difference between symbols and instances

•	 Adjust transparency and color

•	 Apply blending effects

•	 Apply special effects with filters

•	 Position objects in 3D space

This lesson will take about an hour and a half to complete. If needed, 
remove the previous lesson folder from your hard drive and copy the 
Lesson03 folder onto it. 
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Symbols are reusable assets that are stored in your Library. 
The movie clip, graphic, and button symbols are three 
types of symbols that you will be creating and using often 
for special eff ects, animation, and interactivity.
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68  Lesson 3  Creating and Editing Symbols

Getting Started
Start by viewing the final project to see what you’ll be creating as you learn to work 
with symbols. 

1	 Double-click the 03End.swf file in the Lesson03/03End folder to view the final 
project in Flash. 

The project is a static illustration of a cartoon frame. In this lesson, you’ll use 
Illustrator graphic files, imported Photoshop files, and symbols to create an 
attractive image with interesting effects. Learning how to work with symbols is 
an essential step to creating any animation or interactivity.

2	 Close the 03End.swf file. 

3	 Choose File > New. In the New Document dialog box, choose Flash File 
(ActionScript 3.0).

4	 In the Property inspector, click the Edit button next to the Size options to 
change the Stage to 600 pixels wide by 450 pixels high.

5	 Choose File > Save. Name the file 03_workingcopy.fla and save it in the  
03Start folder.
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Importing Illustrator Files
As you learned in Lesson 2, you can draw objects in Flash using the Rectangle,  
Oval, and other tools. However, for complex drawings, you may prefer to create  
the artwork in another application. Adobe Flash CS4 supports native Adobe 
Illustrator files, so you can create original artwork in that application and then 
import it into Flash.

When you import an Illustrator file, you can choose which layers in the file to 
import and how Flash should treat those layers. You’ll import an Illustrator file  
that contains all the characters for the cartoon frame. 

1	 Choose File > Import > Import to Stage.

2	 Select the characters.ai file in the Lesson03/03Start folder. 

3	 Click Open (Windows) or Import (Mac OS).

4	 In the Import to Stage dialog box, make sure all layers are selected. A check 
mark should appear in the check box next to each layer.

If you only want certain layers to be imported, you can deselect the layers you 
want to omit.
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70  Lesson 3  Creating and Editing Symbols

5	 Choose Flash Layers from the Convert layers to menu, and then select Place 
objects at original position. Click OK.

Flash imports the Illustrator graphics, and all the layers from the Illustrator file 
also appear in the Timeline.

Note:##   You can select 
any object displayed in 
your Illustrator file and 
choose to import it as 
a symbol or a bitmap 
image. In this lesson, 
you’ll just import the 
Illustrator graphic and 
take the extra step 
of converting it to a 
symbol so you can see 
the entire process.
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Using Adobe Illustrator with Flash
Flash CS4 can import native Illustrator files and automatically recognize layers, 
frames, and symbols. If you’re more familiar with Illustrator, you may find it easier  
to design layouts in Illustrator, and then import them into Flash to add animation 
and interactivity.

Save your Illustrator artwork in Illustrator AI format, and then choose File > Import 
To Stage or File > Import To Library to import the artwork into Flash. Alternatively, 
you can even copy artwork from Illustrator and paste it into a Flash document.

Importing layers
When an imported Illustrator file contains layers, you can import them in any of the 
following ways:

•	 Convert Illustrator layers to Flash layers

•	 Convert Illustrator layers to Flash keyframes

•	 Convert each Illustrator layer to a Flash graphic symbol

•	 Convert all Illustrator layers to a single Flash layer

Importing symbols
Working with symbols in Illustrator is similar to working with them in Flash. In fact, 
you can use many of the same symbol keyboard shortcuts in both Illustrator and 
Flash: Press F8 in either application to create a symbol. When you create a symbol in 
Illustrator, the Symbol Options dialog box lets you name the symbol and set options 
specific to Flash, including the symbol type (such as movie clip) and registration 
grid location. 

If you want to edit a symbol in Illustrator without disturbing anything else, double-
click the symbol to edit it in isolation mode. Illustrator dims all other objects on the 
artboard. When you exit isolation mode, the symbol in the Symbols panel—and all 
instances of the symbol—are updated accordingly.

Use the Symbols panel or the Control panel in Illustrator to assign names to symbol 
instances, break links between symbols and instances, swap a symbol instance with 
another symbol, or create a copy of the symbol.

For a video tutorial on using symbols between Illustrator and Flash, visit www.
adobe.com/go/vid0198.

Copying and pasting artwork
When you copy and paste (or drag and drop) artwork between Illustrator and 
Flash, the Paste dialog box appears. The Paste dialog box provides import set-
tings for the Illustrator file you’re copying. You can paste the file as a single bitmap 
object, or you can paste it using the current preferences for AI files. (To change the 
settings, choose Edit > Preferences in Windows or Flash > Preferences in Mac OS.) 
Just as when you import the file to the Stage or the Library panel, when you paste 
Illustrator artwork, you can convert Illustrator layers to Flash layers.
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About Symbols
A symbol is a reusable asset that you can use for special effects, animation, or 
interactivity. There are three kinds of symbols: the graphic, button, and movie clip. 
Symbols can reduce the file size and download time for many animations because 
they can be reused. You can use a symbol countless times in a project, but Flash 
includes its data only once. 

Symbols are stored in the Library panel. When you drag a symbol to the Stage, 
Flash creates an instance of the symbol, leaving the original in the Library. An 
instance is a copy of a symbol located on the Stage. You can think of the symbol as 
an original photographic negative, and the instances on the Stage as prints of the 
negative. With just a single negative, you can create multiple prints.

Each of the three kinds of symbols in Flash is used for a specific purpose. You can 
tell whether a symbol is a graphic  , button  , or movie clip  by looking at the 
icon next to it in the Library panel. 

Movie Clip Symbols
Movie clip symbols are one of the most common, powerful, and flexible of symbols. 
When you create animation, you will typically use movie clip symbols. You can 
apply filters, color settings, and blending modes to a movie clip instance to enhance 
its appearance with special effects.

Also notable is the fact that movie clip symbols contain their own independent 
Timeline. You can have an animation inside a movie clip symbol just as easily as 
you can have an animation on the main Timeline. This makes very complex anima-
tions possible; for example, a butterfly flying across the Stage can move from left to 
right as well as have its wings flapping independently of its movement.

Most important, you can control movie clips with ActionScript to make them 
respond to the user. For instance, a movie clip can have a drag-and-drop behavior.

Button Symbols
Button symbols are used for interactivity. They contain four unique keyframes that 
describe how they appear when the mouse is interacting with them. However, but-
tons need ActionScript functionality to make them do something.

You can also apply filters, blending modes, and color settings to buttons. You’ll 
learn more about buttons in Lesson 6 when you create a nonlinear navigation 
scheme to allow the user to choose what to see.
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Graphic Symbols
Graphic symbols are the most basic kind of symbol. Although you can use them for 
animation, you’ll rely more heavily on movie clip symbols. 

Graphic symbols are the least flexible symbols, because they don’t support 
ActionScript and you can’t apply filters or blending modes to a graphic symbol. 
However, in some cases when you want an animation inside a graphic symbol to be 
synchronized to the main Timeline, graphic symbols are useful.

Creating Symbols
In the previous lesson, you learned how to create a symbol to be used for the Deco 
tool. In Flash, there are two ways to create a symbol. The first is to have nothing 
on the Stage selected, and then choose Insert > New Symbol. Flash brings you to 
symbol-editing mode, where you can begin drawing or importing graphics for  
your symbol. 

The second way is to select existing graphics on the Stage, and then choose Modify > 
Convert to Symbol (F8). Whatever is selected will automatically be placed inside 
your new symbol.

Both methods are valid: Which you use depends on your particular workflow pref-
erences. Most designers prefer to use Convert to Symbol because they can create 
all their graphics on the Stage and see them together before making the individual 
components into symbols.

For this lesson, you will select the different parts of the imported Illustrator 
graphic, and then convert the various pieces to symbols. 

1	 On the Stage, select the cartoon character in the hero layer.

Note:##   When you use 
the command Convert 
to Symbol, you aren’t 
actually “converting” 
anything, but rather 
you are placing 
whatever you’ve 
selected inside of a 
symbol.
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2	 Choose Modify > Convert to Symbol (F8).

3	 Name the symbol hero and select Movie Clip for the Type.

4	 Leave all other settings as they are. The Registration indicates the center point 
of your symbol. Leave the registration at the top-left corner.

5	 Select Movie Clip for the Type.

6	 Click OK. The hero symbol appears in the Library.

7	 Select the other cartoon character in the robot layer and convert it to a movie 
clip symbol as well. Name it robot.

You now have two movie clip symbols in your Library and an instance of each 
on the Stage as well.
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Importing Photoshop Files
You’ll import a Photoshop file for the background. The Photoshop file contains 
two layers with a blending effect. A blending effect can create special color mixes 
between different layers. You’ll see that Flash can import a Photoshop file with all 
the layers intact and retain all the blending information as well.

1	 Select the top layer in your Timeline.

2	 From the top menu, choose File > Import > Import to Stage.

3	 Select the background.psd file in the Lesson03/03Start folder. 

4	 Click Open (Windows) or Import (Mac OS).

5	 In the Import to Stage dialog box, make sure all layers are selected. A check 
mark should appear in the check box next to each layer.

6	 Choose the flare layer in the left window.

7	 In the options on the right, choose Bitmap image with editable layers styles.

The movie clip symbol icon appears to the right of the Photoshop layer, 
indicating that the imported layer will be made into a movie clip symbol. The 
other option, Flatten bitmap image, will not preserve any layer effects such as 
transparencies or blending.
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8	 Choose the Background layer in the left window.

9	 In the options on the right, choose Bitmap image with editable layers styles.

10	At the bottom of the dialog box, set the Convert layers to Flash Layers option, 
and select Place layers at original position.

You also have the option of changing the Flash Stage size to match the 
Photoshop canvas. However, the current Stage is already set to the correct 
dimensions (600 pixels x 450 pixels).
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11	Click OK. The two Photoshop layers are imported into Flash and placed on 
separate layers on the Timeline.

The Photoshop images are automatically converted into movie clip symbols 
and saved in your Library. All the blending and transparency information is 
preserved. If you select the image in the flare layer, you’ll see that the Blending 
option is set to Lighten in the Property inspector under the Display section.

12	Drag the robot and the hero layers to the top of the Timeline so they overlap the 
background layers.

About Image Formats
Flash supports multiple image formats for import. Flash can handle JPEG, GIF, PNG, 
and PSD (Photoshop) files. Use JPEG files for images that include gradients and 
subtle variations, such as those that occur in photographs. GIF files are used for 
images with large solid blocks of color or black and white line drawings. Use PNG 
files for images that include transparency. Use PSD files if you want to retain all the 
layer, transparency, and blending information from a Photoshop file.
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Converting a Bitmap Image 
to a Vector Graphic
Sometimes you’ll want to convert a bitmap image to a vector graphic. While Flash 
handles bitmap images as a series of colored dots (or pixels), vector graphics are 
handled as a series of lines and curves. This vector information is rendered on the 
fly, so that the resolution of vector graphics is not fixed like a bitmap image. That 
means you can zoom in on a vector graphic and your computer will always display 
it sharply and smoothly. Converting a bitmap image to a vector often has the effect 
of making it look “posterized” because subtle gradations are converted to editable, 
discrete blocks of color, which can be an interesting effect.

To convert a bitmap to a vector, import the bitmap image into Flash. Select the 
bitmap and choose Modify > Bitmap > Trace Bitmap. The options determine how 
faithful of a trace the vector image will be to the original bitmap.

Below, the left image is an original bitmap and the right image is a vector graphic.

     
Exercise caution when using the Trace Bitmap command, because a complicated 
vector graphic is often more memory and computer-processor intensive than the 
original bitmap image.

Editing and Managing Symbols
You now have multiple movie clip symbols in your Library and several instances 
on the Stage. You can better manage the symbols in your Library by organizing 
them in folders. You can also edit any symbol at any time. If you decide you want 
to change the color of one of the robot’s arms, for example, you can easily go into 
symbol-editing mode and make that change.
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Adding Folders and Organizing the Library
1	 In the Library, right-click/Ctrl-click in an empty space and select New Folder. 

Alternatively, you can click the New Folder button  at the bottom of the 
Library panel.

A new folder is created in your Library.

2	 Name the folder characters.

    

3	 Drag the hero and the robot movie clip symbols into the characters folder.

4	 You can collapse or expand folders to hide or view their contents and keep your 
Library organized.
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Editing a Symbol from the Library
1	 Double-click the robot movie clip symbol in the Library. 

Flash takes you to symbol-editing mode. In this mode, you can see the contents 
of your symbol, in this case, the robot on the Stage. Notice on the top horizontal 
bar that you are no longer in Scene 1 but are inside the symbol called robot.

2	 Double-click the drawing to edit it. You will need to double-click the drawing 
groups several times to drill down to the individual shape that you want to edit.
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3	 Choose the Paint Bucket tool. Select a new fill color and apply it to the shape  
on the robot drawing.

4	 Click on Scene 1 on the top horizontal bar above the Stage to return to the  
main Timeline.

The movie clip symbol in the Library reflects the changes you made. The 
instance on the Stage also reflects the changes you made to the symbol. All 
instances of the symbol on the Stage will change if you edit the symbol.

Note:##   You can 
quickly and easily 
duplicate symbols 
in the Library. Select 
the Library symbol, 
right-click/Ctrl-click, 
and choose Duplicate. 
Or, from the top-right 
Options menu in 
the Library, choose 
Duplicate. An exact 
copy of the selected 
symbol will be created 
in your Library.
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Editing a Symbol in Place
You may want to edit a symbol in context with the other objects on the Stage. You 
can do so by double-clicking an instance on the Stage. You’ll enter symbol-editing 
mode, but you’ll also be able to see its surroundings. This editing mode is called 
editing in place.

1	 Double-click the robot movie clip instance on the Stage. 

Flash dims all other objects on the Stage and takes you to symbol-editing mode. 
Notice on the top horizontal bar that you are no longer in Scene 1 but are inside 
the symbol called robot.

2	 Double-click the drawing to edit it. You will need to double-click the drawing 
groups several times to drill down to the individual shape that you want to edit.
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3	 Choose the Paint Bucket tool. Select a new fill color and apply it to the shape on 
the robot drawing.

4	 Click on Scene 1 on the top horizontal bar above the Stage to return to the 
main Timeline. You can also just double-click any part of the Stage outside the 
graphic to return to the next higher group level.

The movie clip symbol in the Library reflects the changes you made. The instance 
on the Stage also reflects the changes you made to the symbol. All instances of 
the symbol will change according to the edits you make to the symbol.
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Breaking Apart a Symbol Instance
If you no longer want an object on the Stage to be a symbol instance, you can use 
the Break Apart command to return it to its original form.

1	 Select the robot instance on the Stage. 

2	 Choose Modify > Break Apart.

Flash breaks apart the robot movie clip instance. What’s left on the Stage is a 
group, which you can break apart further to edit as you please.

Changing the Size and Position of Instances
You can have multiple instances of the same symbol on the Stage. Now you’ll add 
a few more robots to create a small robot army. You’ll learn how to change the size 
and position (and even rotation) of each instance individually.

1	 Select the robot layer in the Timeline. 
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2	 Drag another robot symbol from the Library onto the Stage. 

A new instance appears.

3	 Choose the Free Transform tool.

Control handles appear around the selected instance.
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4	 Drag the control handles on the sides of the selection to flip the robot so it is 
facing in the other direction.

5	 Drag the control handles on the corner of the selection while holding down the 
Shift key to reduce the size of the robot.
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6	 Drag a third robot from the Library onto the Stage. With the Free Transform 
tool, flip the robot, resize it, and make it overlap the second robot. 

The robot army is growing!

Changing the Color Effect of Instances
The Color Effect option in the Property inspec-
tor allows you to change several properties of any 
instance: These properties include brightness, tint, 
or alpha.

Brightness controls how dark or light the instance 
appears, tint controls the overall coloring, and 
alpha controls the level of opacity. Decreasing the 
alpha value decreases the opacity and increases the 
amount of transparency.

Changing the Brightness
1	 Using the Selection tool, click on the smallest 

robot on the Stage.

2	 In the Property inspector, choose Brightness 
from the Color Effect Style menu.
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3	 Drag the Bright slider to -40%.

The robot instance on the Stage 
becomes darker and appears to 
recede into the distance.

Changing the Transparency
1	 Select the glowing orb in the flare layer.

2	 In the Property inspector, choose Alpha from the 
Color Effect Style menu.

3	 Drag the Alpha slider to a value of 75%. 
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The orb in the flare layer on the Stage becomes more transparent.

Understanding Blend Effects
Blending refers to how the colors of an instance interact with the colors below it. 
You saw how the instance in the flare layer had the Lighten option applied to it 
(carried over from Photoshop), which integrated it more with the instance in the 
Background layer.

There are many kinds of Blending options. Some have surprising results, depending  
on the colors in the instance and the colors in the layers below it. Experiment with 
all the options to understand how they work. The following figure shows some of the  
Blending options and their effects on the robot instance over a blue-black gradient.

Note:##   To reset the 
Color Effect of any 
instance, choose None 
from the Style menu.

Normal Darken Lighten Overlay Hard Light Add Subtract Difference
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Applying Filters for Special Effects
Filters are special effects that you can apply to movie clip instances. In the Chapter 
2 lesson, you used a filter to apply a drop shadow effect to some text. Several filters 
are available in the Filters section of the Property inspector. Each filter has different 
options that can refine the effect. 

Applying a Blur Filter
You’ll apply a blur filter to some of the instances to 
help give the scene a greater sense of depth.

1	 Select the glowing orb in the flare layer.

2	 In the Property inspector, expand the Filters 
section.

3	 Click the Add Filters button at the bottom of the 
Filters section and select Blur. 

The Blur filter appears in the Filters window with 
options for Blur X and Blur Y.

4	 Click the link icon next to the Blur X and Blur Y 
options to link the blur effect in both directions.

5	 Set the Blur X and Blur Y value to 10 pixels. 

More Filter Options
At the bottom of the Filters window  
is a row of options to help you  
manage and apply multiple filters.

The Presets button lets you save a particular filter and its settings so you can apply 
it to another instance. The Clipboard button lets you copy and paste any selected 
filter. The Enable or Disable Filter button lets you see your instance with or without 
the filter applied. The Reset button resets the filter parameters to their default values.
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The instance on the Stage becomes blurry, helping to give an atmospheric 
perspective to this scene.

Positioning in 3D Space
New in Flash CS4 is the ability to position and animate objects in real three- 
dimensional space. However, objects need to be movie clip symbols to move  
them in 3D. Two tools allow you to position objects in 3D: the 3D Rotation tool 
and the 3D Translation tool. The Transform panel also provides information for 
position and rotation.

Understanding the 3D coordinate space is essential for successful 3D placement 
of objects. Flash divides space using three axes: the x, y, and z axes. The x axis runs 
horizontally across the Stage with x=0 at the left edge. The y axis runs vertically 
with y=0 at the top edge. The z axis runs into and out of the plane of the Stage 
(toward and away from the viewer) with z=0 at the plane of the Stage.

Changing the 3D Rotation of an Object
You’ll add some text to your image, but to add a little more interest, you’ll tilt it to 
put it in perspective. Think about the beginning text introduction to the Star Wars 
movies and see if you can achieve the same effect. 

Note:##   It’s best 
to keep the Quality 
setting for filters on 
Low. Higher settings 
are processor-intensive 
and can bog down 
performance, especially 
if you have multiple 
filters.
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1	 Insert a new layer and rename it text.

2	 Choose the Text tool from the Tools panel.

3	 In the Property inspector, select a large-size font with an interesting color that 
will add some pizzazz.

4	 Click on the Stage in your text layer and begin typing your title.

5	 To exit the Text tool, select the Selection tool.

Your text is created, but now you must convert it to a movie clip symbol to 
rotate it and position it in 3D.

6	 While the text on the Stage is still selected, chose Modify > Convert to Symbol.
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7	 In the Convert to Symbol dialog box, enter a descriptive name, select Movie 
Clip type, and click OK.

You now have a movie clip symbol in your Library with your text inside. An 
instance of the movie clip symbol appears on the Stage.

8	 Choose the 3D Rotation tool  .

A circular multicolored target appears on the instance. This is a guide for 
the 3D rotation. It’s useful to think of the guides as lines on a globe. The red 
longitudinal line rotates your instance around the x axis. The green line along 
the equator rotates your instance around the y axis. The circular blue guide 
rotates your instance around the z axis.

9	 Click on one of the guides—red for x, green for y, or blue for z—and drag your 
mouse in either direction to rotate your instance in 3D space.

You can also click and drag the outer orange circular guide to freely rotate the 
instance in all three directions.
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Changing the 3D Position of an Object
In addition to changing an object’s rotation in 3D space, you can move it to a spe-
cific point in 3D space. Use the 3D Translation tool, which is hidden under the 3D 
Rotation tool.

1	 Choose the 3D Translation tool  .

2	 Click on your text.

A guide appears on the instance. This is a guide for the 3D translation. The red 
guide represents the x axis, the green is the y axis, and the blue is the z axis.

3	 Click on one of the guide axes and drag your mouse in either direction to move 
your instance in 3D space. Notice that your text stays in perspective as you 
move it around the Stage.
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Resetting the Rotation and Position
If you’ve made a mistake in your 3D transformations and want 
to reset the position and rotation of your instance, you can use 
the Transform panel.

1	 Choose the Selection tool and select the instance that you 
want to reset.

2	 Open the Transform panel by choosing Window > 
Transform.

The Transform panel shows all the values for the x, y, and z 
angles and positions.

3	 Click the Remove Transform button in the lower-right 
corner of the Transform panel.

The selected instance returns to its original settings.

Understanding the Vanishing Point 
and the Perspective Angle
Objects in 3D space represented on a 2D surface (such as the computer screen)  
are rendered with perspective to make them appear as they do in real life. Correct 
perspective depends on many factors, including the vanishing point and the perspec-
tive angle, both of which can be changed in Flash.

The vanishing point determines where on the horizon paral-
lel lines of a perspective drawing converge. Think of railroad 
tracks and how the parallel tracks converge to a single point 
as they recede into the distance. The vanishing point is usually 
at eye level in the center of your field of view, so the default 
settings are exactly in the middle of the Stage. You can, how-
ever, change the vanishing point setting so it appears above or 
below eye level, or to the right or left.

The perspective angle determines how quickly parallel lines 
converge to the vanishing point. The greater the angle, the 
quicker the convergence, and therefore, the more severe and 
distorted the illustration appears. 

1	 Select an object on the Stage that has been moved or 
rotated in 3D space.

2	 In the Property inspector, expand the 3D Position and 
View section.
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3	 Click and drag on the X and Y values of the Vanishing Point to change the 
vanishing point, which is indicated on the Stage by intersecting gray lines.

4	 To reset the Vanishing Point to the default values (to the center of the Stage), 
click the Reset button.

5	 Click and drag on the Perspective Angle value to change the amount of 
distortion. The greater the angle, the more the distortion.
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Review Questions
1	 What is a symbol, and how does it differ from an instance?

2	 Name two ways that you can create a symbol.

3	 When you import an Illustrator file, what happens if you choose to import layers as 
layers? As keyframes?

4	 How can you change the transparency of an instance in Flash?

5	 What are the two ways to edit symbols?

Review Answers
1	 A symbol is a graphic, button, or movie clip that you create once in Flash and can then 

reuse throughout your document or in other documents. All symbols are stored in 
your Library panel. An instance is a copy of a symbol located on the Stage.

2 	 You can create a symbol by choosing Insert > New Symbol, or you can select existing 
objects on the Stage and choose Modify > Convert to Symbol.

3	 When you import layers in an Illustrator file as layers, Flash recognizes the layers in 
the Illustrator document and adds them as separate layers in the Timeline. When you 
import layers as keyframes, Flash adds each Illustrator layer to a separate frame in the 
Timeline and creates keyframes for them. 

4	 The transparency of an instance is determined by its alpha value. To change the 
transparency, select Alpha from the Color Effects menu in the Property inspector, and 
then change the alpha percentage.

5	 The two ways to edit symbols are to either double-click the symbol in the Library to 
enter symbol-editing mode or to double-click the instance on the Stage to edit in place. 
Editing a symbol in place lets you see the other objects around the instance.
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